Fix low keyboard velocity (Kontakt)


Not sure where to ask about this but thought the great community here could help me?

I’ve just got Spitfire’s British Drama Toolkit and I’m having trouble as even if I seriously hammer my keyboard I’m barely accessing the ‘Soft’ layer. I’ve wondered about levels before now but this library seems to highlight the issue. I don’t know whether the issue is with Kontakt, my keyboard (Yamaha MX88) or something else, assuming it’s not the library.

Any help would be amazing! Cheers


First off, I would want to see what data is reaching the kontakt plugin. I use midiMonitor, a free plugin from a company that seems to have gone out of business. The plugin can still be found here:

You should be able to register input from your keyboard from low (single digit values) to high (above 110). Max is 127.


Thanks Sid, think I’ve managed to get to something usable.

I downloaded that vst but Cubase blacklisted it so downloaded MIDI Loupe from the app store. My setup is far from perfect as I’ve struggled to get it to register anything and I get a strange constant stream of MIDI messages ‘some other message’ from the single connected MIDI source whether going through the my ESI MIDI box or the Focusrite Interface. Had to quickly tick, play and untick it to stop them shooting up off the page.

Anyway I’ve figured out how to change through the 4 velocity curves on the MX88 and ‘Wide’ seems much better than the others (Normal, Soft, Hard). With a custom curve in the BDT instruments I’m happy now. Just a bit puzzled by those constant MIDI messages :confused:



That looks like a stuck CC (continuous controller) knob. I would check the pitch bend and mod wheel and any other controller knobs. Give them a little play and back to the zero position, and check for dust. If you watch your MIDI loupe while you do it, you may get some feedback. The MX88 seems to have 4 or 5 CC knobs. Good luck.


As well as the MIDI CCs, the MX88 also sends Real-Time MIDI messages like MIDI Clock and Song Position, etc. - as shown on the MIDI Implementation Chart near the end of this document:

For example, MIDI Clock is roughly the equivalent of someone counting time, so that the rest of a band, ensemble or orchestra knows what tempo they should play at. There are 24 MIDI Clock messages per quarter note, so your experience of trying to record the full MIDI data stream could just be showing these other MIDI messages.

Pitch Wheels, Modulation Wheels and MIDI CCs are usually programmed so that they only send out MIDI messages when their position changes - the program looks for when a change in the measured position exceeds a threshold. It is unusual for a Pitch Wheel, Modulation Wheel or CC to send out messages all the time, and that would probably be considered to be a fault. Yamaha products have ‘hidden’ built-in test routines in their firmware that can be used for checking the correct operation of Pitch Wheels, Modulation Wheels and MIDI CCs, and a service technician could use these test routines to check that you do not have a faulty one.

However, I think that the most likely explanation is that you may be seeing some Real-Time MIDI messages, rather than a faulty controller. From the MIDI Implementation Chart, these Real-Time messages would seem to be normal and should not affect the velocity response.


Working backwards from the data shown in the screenshot, the messages seem to occur, on average, about every 27.6 ms. If they are MIDI Clock messages, then this would be consistent with a tempo of just under 91 bpm.


Hi, one other place to check might be to look at the Expression. If it’s down too low, your volume will be low. You can click on the wrench in the plug-in and you’ll see that on the far right. I use Native Instruments Kontrol keyboard and I needed to map it to the slider. If you find that it’s not mapped to your controller, right click and select learn midi cc. Hope that helps



Wow thanks, I didn’t notice those charts at the bottom of the manual.

I’ve just gone into the menu again on the mx88 and noticed 'ClockOut=On and turned it to Off. MIDI input in MIDI Loupe instantly stops and starts when switching this. As outside of this monitor I don’t notice the clock is it better to just leave it on or off?

Much appreciated info btw! Cheers


Hi Ken, thanks yeah expression is up. I have it mapped to the mod wheel.

All seems better now I’ve switched the mx88 velocity curve to ‘wide’ from ‘normal’. :slight_smile:


@CreativeDan MIDI Implementation Charts are fine detail that most people won’t ever need to read!

If you turn off the clock then any MIDI devices (that are using that timing source for sync/timing) will stop. If you aren’t using it as your master timing source then it is fine to turn it off - but remember that in the future, if you want to sync any other devices from it then you will need to turn it back on again.

(Caveats: If you are using a DAW then that may well be your master clock source for other MIDI gear (drum machines, expanders, keyboards with arpeggiators)… If you regularly change between using a DAW and your Master keyboard as your timing source, then you may need to turn the MIDI Clock on your master keyboard off and on (a post-it note on the top of your master keyboard showing the current MIDI Clock state: On or Off, can be very useful and saves menu-diving! And for other forum members reading this - if you are using a complex Master Keyboard that has an internal sequencer and MIDI routing (the Yamaha Montage or MODX are good examples), then you will need to configure it carefully to ensure that the routing of the various MIDI Clocks is correct.)